Order Confirmation Interruption
Incident Report for Malomo
Resolved
We have verified that the fix put in place yesterday (August 1) at 5pm ET has resolved this issue.
Posted Aug 02, 2022 - 18:33 EDT
Monitoring
Earlier today, we identified an interruption to our Order Confirmation event data. Our Malomo: ShopifyOrderCreated metric was not being sent to our app integrations as expected. Orders that were placed earlier today (August 1), did not receive our Malomo: ShopifyOrderCreated metric.

At 5pm ET, we implemented a fix and we are currently monitoring the situation. Shopify orders that were placed today (August 1) before 5pm ET will see delayed Order Confirmation updates as our system catches up this evening. Orders placed after 5pm ET will see immediate updates, as expected.

Last Wednesday, July 27, we implemented a safeguard in our system to ensure we were preventing notifications from triggering inadvertently, however, that safeguard was incorrectly filtering order confirmation notifications for the first of the month. This was the cause of the issue. Once we identified the issue, we quickly updated the safeguard logic to correctly trigger order confirmation emails.

If you trigger Klaviyo email or SMS notifications off the Malomo: ShopifyOrderCreated metric, you were likely affected by this interruption and any Order Confirmation notifications were not sent. As our system updates, these order notifications will be sent.

Our team will continue to monitor the situation over the next 24 hours.
Posted Aug 01, 2022 - 19:00 EDT
This incident affected: Malomo - Integrations (Shopify).