USPS incorrectly marking packages as “Return to Sender”
Incident Report for Malomo
Resolved
After monitoring this issue we have determined that the problem is fixed. USPS packages should now be correctly marked as "delivered" instead of "return-to-sender".
Posted Feb 10, 2023 - 09:45 EST
Update
We are continuing to monitor for any further issues.
Posted Feb 10, 2023 - 09:41 EST
Monitoring
We have identified the issue and implemented a solution. We will continue to monitor the situation throughout the day.
Posted Feb 07, 2023 - 12:25 EST
Update
We are continuing to investigate this issue.
Posted Feb 07, 2023 - 11:32 EST
Investigating
Yesterday, we identified an issue with USPS marking some packages as “Return to Sender”, right before marking the same package as “Delivered”. We are currently working with our integration partner to determine why they are sending this event for packages that have been successfully delivered.

Customers using Return to Sender flows with our integrations may be affected, causing some shoppers to receive Return to Sender notifications for USPS packages that were successfully delivered. We recommend that customers using Return to Sender flows disable them until the issue is resolved.

Customers using the Problem Orders feature may see higher than average Returned to Sender numbers on the Problem Orders report.

We will keep this post updated as we work to resolve the issue.
Posted Feb 07, 2023 - 09:00 EST
This incident affected: Malomo - Integrations (Klaviyo, Attentive).