Delayed Order Created & Shipment Created Events
Incident Report for Malomo
Resolved
This incident has been resolved.
Posted Jul 24, 2023 - 15:38 EDT
Monitoring
At 10:10pm EDT, we implemented a fix and are currently monitoring the situation. Shopify orders that were placed between Friday, July 21 at 4:22pm EDT and Sunday, July 23 at 10:10pm EDT will see delayed Order Confirmation and Shipment Created updates as our system catches up. Orders placed after after July 23 at 10:10pm EDT will see immediate updates, as expected.

Our team will continue to monitor the situation over the next 24 hours.
Posted Jul 24, 2023 - 11:02 EDT
Investigating
This evening, we identified an interruption to our Shopify integration beginning Friday, July 21 at approximately 4:22pm EDT, which impacted events received from Shopify. Any orders placed after this time are being impacted in the following ways:

• The Malomo: ShopifyOrderCreated metric is not being sent to our app integrations
• The Malomo: ShipmentCreated metric is not being sent to our app integrations
• Orders are not appearing in the Malomo dashboard

If you trigger Order Confirmation emails or SMS from the Malomo: ShopifyOrderCreated metric in any integration, these order notifications likely have not been sent. If you trigger Just Shipped emails or SMS from the Malomo: ShipmentCreated metric in any integration, these shipping notifications likely have not been sent.

We are currently investigating the issue and will provide updates as we learn more.
Posted Jul 23, 2023 - 21:58 EDT
This incident affected: Malomo - Integrations (Shopify).